blob: b47063f2dae36188faa52ec94c6113dc68c0797e [file] [log] [blame]
name: anansi
version: 0.4.8
license: GPL-3
license-file: license.txt
author: John Millikin <john@john-millikin.com>, Dirk Laurie <dirk.laurie@gmail.com>
maintainer: John Millikin <john@john-millikin.com>
build-type: Simple
cabal-version: >= 1.6
category: Development
stability: experimental
homepage: https://john-millikin.com/software/anansi/
bug-reports: mailto:jmillikin@gmail.com
synopsis: Simple literate programming preprocessor
description:
Anansi is a preprocessor for literate programs, in the model of NoWeb or
nuweb. Literate programming allows computer code and a human-readable
document to be generated from the same source. Compared to NoWeb,
Anansi&#x2019;s primary benefits are the ability to include separate files,
and to automatically generate an entire directory tree from a project
without having to enumerate each output.
.
This package is split into a library and an executable. The executable is
suitable for simple cases, such as generating basic HTML or LaTeX. The
library is useful for users who would like to write their own output formats
(called &#x201C;looms&#x201D;).
source-repository head
type: git
location: https://john-millikin.com/code/anansi/
source-repository this
type: git
location: https://john-millikin.com/code/anansi/
tag: anansi_0.4.8
library
hs-source-dirs: lib
ghc-options: -Wall -O2
if impl(ghc>=7.10)
ghc-options: -fno-warn-tabs
build-depends:
base >= 4.0 && < 5.0
, bytestring >= 0.9
, containers >= 0.1
, monads-tf >= 0.1 && < 0.2
, options >= 1.0 && < 2.0
, parsec >= 3.0 && < 3.2
, system-argv0 >= 0.1 && < 0.2
, system-filepath >= 0.3.1 && < 0.5
, system-fileio >= 0.2.1 && < 0.4
, text >= 0.7
exposed-modules:
Anansi
other-modules:
Paths_anansi
Anansi.Loom.Debug
Anansi.Loom.HTML
Anansi.Loom.LaTeX
Anansi.Loom.Markdown
Anansi.Loom.NoWeb
Anansi.Main
Anansi.Parser
Anansi.Tangle
Anansi.Types
executable anansi
main-is: Main.hs
hs-source-dirs: lib,src
ghc-options: -Wall -O2
if impl(ghc>=7.10)
ghc-options: -fno-warn-tabs
build-depends:
base >= 4.0 && < 5.0
, bytestring >= 0.9
, containers >= 0.1
, monads-tf >= 0.1 && < 0.2
, options >= 1.0 && < 2.0
, parsec >= 3.0 && < 3.2
, system-argv0 >= 0.1 && < 0.2
, system-filepath >= 0.3.1 && < 0.5
, system-fileio >= 0.2.1 && < 0.4
, text >= 0.7