Remove maximum dependency versions for most dependencies.

Bump version to 0.4.19.
diff --git a/enumerator.cabal b/enumerator.cabal
index 50c3c5b..ff61b40 100644
--- a/enumerator.cabal
+++ b/enumerator.cabal
@@ -1,6 +1,5 @@
 name: enumerator
-version: 0.4.18
-synopsis: Reliable, high-performance processing with left-fold enumerators
+version: 0.4.19
 license: MIT
 license-file: license.txt
 author: John Millikin <jmillikin@gmail.com>
@@ -12,8 +11,8 @@
 stability: experimental
 homepage: https://john-millikin.com/software/enumerator/
 bug-reports: mailto:jmillikin@gmail.com
-tested-with: GHC==6.12.1
 
+synopsis: Reliable, high-performance processing with left-fold enumerators
 description:
   Typical buffer&#x2013;based incremental I/O is based around a single loop,
   which reads data from some source (such as a socket or file), transforms
@@ -135,7 +134,7 @@
 source-repository this
   type: bazaar
   location: https://john-millikin.com/branches/enumerator/0.4/
-  tag: enumerator_0.4.18
+  tag: enumerator_0.4.19
 
 library
   ghc-options: -Wall -O2
@@ -143,10 +142,10 @@
 
   build-depends:
       base >= 4.0 && < 5.0
-    , transformers >= 0.2 && < 0.3
-    , bytestring >= 0.9 && < 0.10
-    , containers >= 0.1 && < 0.5
-    , text >= 0.7 && < 0.12
+    , transformers >= 0.2
+    , bytestring >= 0.9
+    , containers >= 0.1
+    , text >= 0.7
 
   exposed-modules:
     Data.Enumerator